Masih bermain dengan mikrotik,disini saya mencoba untuk membagi bandwith untuk semua client agar sama rata.
Contoh Kasus
bandwidth yang didapat dari ISP adalah upto 2 MBps dan jumlah client ada 10 unit .maka apabila ada 1 client akan mendapatkan total seluruh bandwidth, apabila ada 2 client masing-masing mendapatkan upto 1mbps, demikian seterusnya dan juga diberikan batasan untuk mencegah penggunaan download accerelator yang akan menyedot banyak bandwidth.
Contoh untuk 10 komputer, IP=192.168.0.2-192.168.0.11
ether1=public, ether2=lan (local)
Code :
Untuk trafik upload
/ip firewall mangle add chain=prerouting src-address=192.168.0.2 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.3 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.4 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.5 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.6 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.7 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.8 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.9 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.10 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.11 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
Untuk trafik download
/ip firewall mangle add chain=forward src-address=192.168.0.2 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.3 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.4 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.5 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.6 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.7 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.8 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.9 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.10 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.11 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward connection-mark=personal-conn in-interface=ether1 action=mark-packet new-packet-mark=personal-down passthrough=no
Pada menu Queue
/queue tree add name=down parent=ether2 queue=default
/queue tree add name=up parent=global-in queue=default
/queue type add name=auto-down kind=pcq pcq-rate=0 pcq-classifier=dst-address pcq-total-limit=2000
/queue type add name=auto-up kind=pcq pcq-rate=0 pcq-classifier=src-address pcq-total-limit=2000
/queue tree add name=per-down packet-mark=personal-down parent=down queue=auto-down max-limit=200000
/queue tree add name=per-up parent=up packet-mark=personal-up queue=auto-up max-limit=200000
Contoh Kasus
bandwidth yang didapat dari ISP adalah upto 2 MBps dan jumlah client ada 10 unit .maka apabila ada 1 client akan mendapatkan total seluruh bandwidth, apabila ada 2 client masing-masing mendapatkan upto 1mbps, demikian seterusnya dan juga diberikan batasan untuk mencegah penggunaan download accerelator yang akan menyedot banyak bandwidth.
Contoh untuk 10 komputer, IP=192.168.0.2-192.168.0.11
ether1=public, ether2=lan (local)
Code :
Untuk trafik upload
/ip firewall mangle add chain=prerouting src-address=192.168.0.2 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.3 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.4 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.5 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.6 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.7 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.8 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.9 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.10 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
/ip firewall mangle add chain=prerouting src-address=192.168.0.11 in-interface=ether2 action=mark-packet new-packet-mark=personal-up passthrough=no
Untuk trafik download
/ip firewall mangle add chain=forward src-address=192.168.0.2 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.3 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.4 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.5 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.6 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.7 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.8 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.9 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.10 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward src-address=192.168.0.11 action=mark-connection new-connection-mark=personal-conn passthrough=yes
/ip firewall mangle add chain=forward connection-mark=personal-conn in-interface=ether1 action=mark-packet new-packet-mark=personal-down passthrough=no
Pada menu Queue
/queue tree add name=down parent=ether2 queue=default
/queue tree add name=up parent=global-in queue=default
/queue type add name=auto-down kind=pcq pcq-rate=0 pcq-classifier=dst-address pcq-total-limit=2000
/queue type add name=auto-up kind=pcq pcq-rate=0 pcq-classifier=src-address pcq-total-limit=2000
/queue tree add name=per-down packet-mark=personal-down parent=down queue=auto-down max-limit=200000
/queue tree add name=per-up parent=up packet-mark=personal-up queue=auto-up max-limit=200000
script ini sdh saya pake boss,, pake IDM-pun juga tershaping dengan baik kok..
ada yg kelewatan... jgn pake webproxy internal MT yah... soalnya kl webproxy MT diidupin bobol deh...
ada yg kelewatan... jgn pake webproxy internal MT yah... soalnya kl webproxy MT diidupin bobol deh...
[MIKROTIK] Membagi Bandwidth Sama Rata Metode PCQ Mikrotik
BalasHapusSumber: MR-EKOAPRIADI - http://www.mr-ekoapriadi.net/2013/04/tutorial-membagi-bandwidth-sama-rata.html